• Members 2 posts
    June 20, 2021, 2:19 a.m.

    I picked up a cheap vinyl cutter. A JSI-Cut CP-24. It looks precisely like a Creation PCut CP-630, except not quite as long. JSI strongly implies that it's a Copam. The motherborard has Kingcut markings. I think these are all probably made by the same people but with subtle differences. The guy i bought it from said it had been in use but he didn't know anything about it other than that and didn't have the software. My guess from chip markings is that it was made in about 2007. It has a DB25 serial port and came with a null modem cable and a ch340 based usb-to-serial cable.

    The control panel on the cutter looks and behaves just like videos of the CP-630 i have seen with the exception that it does not have a baud rate item to set.

    Yesterday i struck out trying to set up inkcut on my Pinebook Pro with Manjaro ARM (current) and then later on an amd64 machine with xubuntu 21.04. I think i ran into the same library issue that is biting lots of people.

    So today on a win10 laptop I installed inkscape 1.1, python 3.8, and installed inkcut per the instructions on the website. There don't seem to be any real errors in the console when i try to use it, but the cutter doesn't move. I tried both the regular serial and qt serial options.

    I tried the preset for the cp-630, and tried the generic driver, fiddled with settings a bunch of ways, and no dice.

    Then I installed the demo version of sure cuts a lot 5, and if i select the preset for "Copam" it Just Works. Sort of. I don't really know what i am doing after all. But the machine moves and cuts stuff. The rest is finesse, right?

    SCAL5 exposes none of the serial port settings. Not baud rate, or anything. I suspect there are ways to interrogate windows to figure out what is going on.

    The Copam CP-2500 is in the supported list for inkcut, but there's no preset for it.

    Any clues what to try next?

  • Members 2 posts
    June 23, 2021, 2:03 a.m.

    I think what the lcd on the control panel flashes is actually "CT 24" but the sticker on the back just says "JSI 24"?

    Anyway, after repairing the internal serial cable, which was very badly assembled, and setting inkcut to use the generic driver and a raw (rather than qt) serial port on my pinebook pro, 9600bps, rts/cts flow control - it's an rs232 printer with a db25 female, a "null modem" cable, and a ch340 based usb-to-serial cable - it is cutting reasonably well considering i don't know what the hell i am doing.

    Sometimes if i try using the "control" pane to move the vinyl or the head several seconds will pass before it reacts. Maybe it is a buffer on the machine, oddity in the software, who knows.