• Members 7 posts
    May 13, 2020, 10:51 p.m.

    Been working with inkcut for over a year now, but after a system update last week stop working, now it crashes at some point when your sending a file. I thought was some python version problem, but i tried ubuntu 18 (3.6), ubuntu 19 (3.7) and ubuntu 20 (3.8) .. all fresh installations, diferent machines, and same errors. So has to be something you download and install that is included in the current installations instructions. Is there a workarround to this problem? I use this everyday at work.. and really .. really trying to avoid to go back to windows. Thanks in advance.


    PNG, 122.9 KB, uploaded by Memo on May 13, 2020.

  • edit

    Thread title has been changed from INKCUT STOP WORKING AFTER SYSTEM UPDATE UBUNTU.

  • Members 7 posts
    May 14, 2020, 12:26 a.m.

    Solved!!! ...

    Sorry i cant give you step by step what i did, since was a 2 days trial and error.. but i hope it can help to anyone having the same issue. And avoid updates just in case.

    1. Have Ubuntu 20, that uses python 3.8, so first thing was to install python 3.7, and set it as default.
    2. sudo apt install python3-pip
    3. sudo python3.7 -m pip install pyqt5
    4. sudo apt install python3-pyqt5.qtsvg libcups2-dev
    5. sudo python3.7 -m pip install pyqt5 (i know.. but i did it again, since was the only way it worked for me)
    6. python3.7 -m pip install enaml==0.10.4
    7. python3.7 -m pip install inkcut
    8. pip3 install atom==0.4.3
    9. add your user to dialout or tty group and reboot