• Members 5 posts
    May 7, 2019, 3:07 p.m.

    For Windows Users suing Windows 10, please use the following process when trying to install Inkcut as there is a major problem with the Twisted Package that you will face.

    From the Page,

    Steps:

    Run CMD as admin before installing any dependencies

    Installation of Python and the Pyqt5 dependencies will present no problems,

    When trying to install the inkcut package dependencies, you will eventually hit a wall with the Twisted package error which will indicate that Visual C++ V14.0 is needed to complete the installation.

    After following the Link from the error message, and installing Visual Studio Installer from the Tools option, select the Visual Studio Build Tools 2019> C++ Build Tools and install all options

    From the CMD terminal, run the following command pip3 install Twisted[windows_platform] to ensure that the Twisted for Win32 is installed as it is always works

    Then finally run the pip3 install inkcut. It will run without any errors

    Run inkcut and watch the window pop-up

    Also, don't forget to add the .py scripts from the available download package to the extensions folder in Inkscape before running as usual.

  • Members 2 posts
    June 2, 2019, 7:34 p.m.

    This worked great however I had to copy 2 files, rc.exe and it’s dll to the VS folder that it builds from. Can get exact path if needed.

    However I am new to Inkscape so I’m not sure how to add the python scripts to the extensions folder when pip3 installs? Can you help with that so I can load directly into inkcut?

  • Members 2 posts
    June 2, 2019, 9:20 p.m.

    Well I figured it out, downloaded the source code package and put them in my user extensions as it didn’t work in the system extensions.