• Members 8 posts
    Jan. 30, 2022, 1:11 a.m.

    Problem is with the RUINATION of two of the best packages run in Linux-- Inkscape and Python.

    How to fix--
    Get out an old distro and old version of Inkscape along with a backup of the original INKCUT extension. Plop it in to the right folder- and be done with it.

    I've spent days trying to figure this out- twice in the last 3 months to operate a little hpgl plotter to cut a couple things that I volunteered to do. Next time I think about volunteering- I'd be better off to just go stand on the highway. I've wasted more time trying to get my system to run InkCut. And I want to tell others- don't bother. Google and Windows along with the Google bootcamp are making drastic changes to both Inkscape and Python. They are not making these changes following the tried and pure Linux way-- but deprecating and ruining functions-- completely obliterating modules like Inkcut. And meanwhile these same idiots braggarts are posting about changes they have made to the Inkscape GUI interface so that it more replicates Android or Windows in some cases--they have made slider bar functions that can be moved back and forth to amaze their own eyeballs while adjusting gradients-- but they forgot that without Python compatibility, Inkscape freezes up our entire systems. If we wanted Windows- it was free for quite awhile. Apparently Linux users did not like Windows. So why are we allowing this transition?
    Inkcut was as far as I know, the only free (and great) HPGL driver available. It kept the landfills free of plotters that if only for Windows would be end up in the landfill and replaced with new to keep up with the ever popular Windows obsolescent protocol.

    I will spare everyone the rest of my frustration. I came from being a computer builder, a Windows Admin before PnP existed- when everything had to be done manually. I installed sophisticated hardware- even virtual equipment before it ever hit the market for use in mapping and GIS. I was an advanced AutoCAD user, a lover of DOS and came to Linux crippled by those habits. But I came to love Linux- admire module and package writers and teams- and am extremely frustrated and angry about what is happening to a project so many people contributed to. To see Microsoft Windows and Google get their claws into yet another project that people built--to take over and profit like they did with Android- is really wrong. Now we can't even have a f...ng HPGL plot driver. Nothing is sacred. We are now experiencing the same obsolescent protocol Windows implemented but this time it is more the confiscation protocol--- not HPGL, no 3D printers, no Plotters for the non-commercial users.

    Thank you Inkcut for what you did design and for the many years of use I had from it reliably until 2021.

  • Feb. 5, 2022, 2 a.m.

    Thank you Inkcut for what you did design and for the many years of use I had from it reliably until 2021.

    Looks like the link to the original version got lost after I updated my site. Re-uploaded it to codelv.com/assets/uploads/inkcut-1.0.tar.gz That should work for older versions of Inkscape.

  • Members 8 posts
    March 17, 2022, 9:08 a.m.

    @frmdstryr Thank you for uploading that version. I'm writing to give you a Good News Update-- (starts off bad but ends good.)
    Inkscape 0.92 would not install on my Manjaro system so I was forced to reinstall Inkscape 1.1.2 and Inkcut 2.1.3. But for whatever reason, the Inkcut extension showed up in Inkscape's menu and opened. Ownership of ttyUSB0 had to be corrected for the plotter to be visible to Inkcut, within Linux- (not sure why when other installs tty just worked). Objects to plot appeared in Inkcut's interface and Inkcut recognized my plotter/ tty port. But, now there was a send error. The Inkcut log was helpful --because to me it was cryptic, and inspired me to learn a bit about Python(3.10) hoping to one day repair or convert Inkcut to run on the newer Python.

    Here's the Good News: Finally--One little experiment resolved the problem and Inkcut successfully plotted a file!!!

    The change was to plugin.py, line 810: from yield async_sleep(d/rate) to yield async_sleep(int(d/rate))
    (On line 702, rate is assigned a value that has a divide by 1000.0. Maybe rate needs to be a float someplace else so left it alone.)

    The log showed problems downstream @ .local/lib/python3.10/site-packages/enaml/application.py, q_deferred_caller.py and inkcut/core/util.py.
    The error message was pretty damn sensible once I understood a little about Python! In case someone else has a problem this was the error msg:
    TypeError: arguments did not match any overloaded call:
    singleShot(int, PYQT_SLOT): argument 1 has unexpected type 'float'
    singleShot(int, Qt.TimerType, PYQT_SLOT): argument 1 has unexpected type 'float'

    I'm soOOO happy to have Inkcut working again! The software that came with my plotter-SignBlazer, required older Windows but after my OS was ruined by a failed Win10 upgrade, I switched to Linux. Your Inkcut, in conjunction with Inkscape is as good if not better than original software. Thank you for your project!

  • March 21, 2022, 1:33 a.m.

    Glad you got it working!

    Qt seems to have changed implicit conversions of int/float in a recent version. Sounds like the wrapper needs updated.

  • Members 8 posts
    March 21, 2022, 5:08 a.m.

    That makes sense---
    But I spoke too soon--and wondering if I need to revert the change back to the original. While installing font-manager on 3-18, Manjaro updated my system. After the update, my plotter refused to communicate.

    I think too the new Inkscape Extension criteria has changed but the Inkcut extension shows up (very slowly). Inkcut extension ran but the plotter doesn't respond. A rollback of Inkscape didn't help. Using Inkcut as a stand alone opens fine. But the plotter doesn't respond. The device/plotter settings are correct, the svg file loads, a trace of output appears on screen and there's coordinates in the console- but the plotter does nothing at all. The port seems as though it is recognized- using dmesg --follow, lsusb, dmesg grep | tty, etc..

    Would you be willing to figure out what happened? In case you might be interested, attached you should find the Inkcut log (that shows it both working on 3-17 and not working 3-20),the pamac history (affected update was 3-18), and a Pacmac warning from just after the update.


    Text, 795 bytes, uploaded by LaurieBlewFuse on March 21, 2022.


    Text, 18.4 KB, uploaded by LaurieBlewFuse on March 21, 2022.


    Text, 642.5 KB, uploaded by LaurieBlewFuse on March 21, 2022.

  • Members 8 posts
    March 21, 2022, 5:27 a.m.

    Also here's the original inkcut log before I made the changes--


    Text, 31.3 KB, uploaded by LaurieBlewFuse on March 21, 2022.

  • March 27, 2022, 6:41 p.m.

    I sent a patch for the error you found. I hit the same error after updating my old computer so thanks for pointing that out!

    As far as it not communicating can you try the "Qt SerialPort"?

    Also I have a pull request pending that lets you just copy and paste right from inkscape which sort of makes the extension not necessary.

  • Members 8 posts
    March 29, 2022, 10:52 a.m.

    Sorry about your computer. Wish there was a way to test an update in advance.
    My plotter didn't respond with the Qt SerialPort. But, Inkcut, Live Screen and Console appeared to be working. The plotter just doesn't want to connect. Since earlier I'd experimented installing Inkcut in venv, I cleared out the logs and .json files in .config, and tried again. Surprisingly, QtSerialPort wasn't available. There were two selections under the Connections tab- Serial and (if I remember right) Parallel- or maybe it was printer. I'd closed out of all it and decided to go back to see which type it was only to find the Connection Type had been populated with 6 options (serial, qtserialport, parallel, printer, raw & save). With the config cleaned again, ran it again but had the same result. Here's the log files in case they help- you'll have to go by the timestamps to determine the order. I sent an email to FTDI who makes the chip for my plotter (Creation PCut ct630) -their instructions don't work- to start with rmmod usbserial doesn't work because now it's built in. They squawk about the ftdi_sio module not being correct in Linux- but don't know how old their instructions are or what's been done with the kernel ftdi_sio. It looks like many ftdi chips are listed but I'm too stupid to be able to tell if the one needed is in that list- or substituted. ?



    Text, 75.0 KB, uploaded by LaurieBlewFuse on March 29, 2022.


    Text, 13.1 KB, uploaded by LaurieBlewFuse on March 29, 2022.


    Text, 24.6 KB, uploaded by LaurieBlewFuse on March 29, 2022.