• Members 2 posts
    April 29, 2021, 3:02 p.m.

    I have just installed Inkcut on Linux Mint 20.1 Cinnamon but I am not able to run it through the command line/terminal.
    When I type in "inkcut" I get the below error. What am I missing? I have also attached the only log file that has anything in it.

    Sorry, an error prevented Inkcut from starting
    This is either a bug or a required library may be missing on your system. As always you can request help on the forums at inkcut.org.
    First try to restart the application. If the error persists you can try clearing the saved settings in /home/jesse/.config/inkcut and restart the application again.
    If that still doesn't work please report a new issue at github.com/codelv/inkcut with the following error:
    plugin = manifest.factory()
    File "/home/jesse/.local/lib/python3.8/site-packages/inkcut/preview/manifest.enaml", line 24, in plugin_factory
    from .plugin import PreviewPlugin
    File "/home/jesse/.local/lib/python3.8/site-packages/inkcut/preview/plugin.py", line 12, in
    import pyqtgraph as pg
    File "/home/jesse/.local/lib/python3.8/site-packages/pyqtgraph/init.py", line 13, in
    from .Qt import QtGui, mkQApp
    File "/home/jesse/.local/lib/python3.8/site-packages/pyqtgraph/Qt.py", line 137, in
    from PyQt5 import QtGui, QtCore, QtWidgets, sip, uic
    ImportError: cannot import name 'sip' from 'PyQt5' (/usr/lib/python3/dist-packages/PyQt5/init.py)
    and include the logs from /home/jesse/.config/inkcut/logs.

    Thanks for any help


    Text, 21.2 KB, uploaded by jwelch2811 on April 29, 2021.

  • Members 1 post
    May 1, 2021, 2:34 a.m.

    Hello Guys, I have just installed mint 20.1 and get same error.

    thanks for any help.

  • Members 2 posts
    May 6, 2021, 4:47 p.m.

    This solved the problem for me:
    pip3 install pyqt5==5.14.0